We are disappointed to share that we will not be able to offer a Catalina-compliant version of AccountEdge - now or in the future.

IMPORTANT NOTICE FOR MAC USERS

We are disappointed to share that we will not be able to offer a Catalina-compliant version of AccountEdge - now or in the future. Read more.

  • Section: Troubleshooting
  • Last updated: July 30, 2019, 3:43 p.m.

macOS 10.12 Sierra Compatibility

The 2016 versions of AccountEdge are compatible with macOS 10.12 Sierra and at this time (September 20, 2016) we are not aware of any issues with AccountEdge 2016. If any issues are reported we will update this article.

Users running older versions of AccountEdge should consider upgrading to the latest version of AccountEdge (AccountEdge 2016) before installing macOS 10.12 Sierra.

UPDATE: Users on versions earlier then AccountEdge 2012 and AccountEdge Basic v2 are not going to be able to register AccountEdge on the macOS 10.12 Sierra Operating System. To be able to register and use the software on macOS 10.12 Sierra you need to upgrade to a newer version of AccountEdge.